Wie man es nicht macht…

Der Steuerberater eines Kunden möchte gerne auf eine bestimmte Software zugreifen die leider nur innerhalb des Konzern-Netzwerkes läuft. Also für den StB beim Kunden einen kleinen Rechner für den Fernzugriff in die Ecke gestellt.

Die Software möchte gerne den Internet Explorer 11, den installieren wir mithilfe des Mozilla Firefox flink nach. Kaum waren die magischen 3 Worte „mal eben schnell…“ gesprochen ging der Ärger los: IE 11 ist angeblich bereits installiert, kann nicht neu installiert weden. Nach langem Suchen wurde die Ursache gefunden: Der IE 11 war nicht installiert, dafür aber ein Update für den IE 11.

Das Update deinstalliert, neuer Versuch. Sah gut aus nur am Ende brach der Installer ohne Fehlercode ab. Mir schwante da was …. statt „Keinem Internetexplorer“ war nun der IE 8 auf dem Computer, also den auch deinstalliert. Beim Booten zog sich der Rechner mit einem „Eine Installation hat nicht funktioniert, wird rückgängig gemacht“ für eine Stunde in seine Meditationsnische zurück. Paar weitere Reboots und Deinstallationen später konnte dann der IE 11 endlich installiert werden.

Schnell den StB in die Konzernsoftware als User eingtragen und schon geht … nichts. Angeblich stimmt das Kennwort nicht. Durchaus denkbar – wenn man über eine recht lahme VPN Verbindung tippt kann da alles Mögliche angekommen sein, selbst 2x hintereinander beim Kennwortvergleich. Also auf dem Remotecomputer eine Textdatei aufgemacht, alles im Klartext eingetippt und dann per Copy & Paste die Daten eingetragen.

Perfekt. Anmeldung geht, ich stehe vor den Toren der eigentlichen Anwendung. Und es lädt, es lädt, es lädt…. 1 Stunde mit dem Support telefoniert. Auf dem einen Rechner geht es, auf dem anderen nicht. Die Kollegen konnten mir aber zumindest verraten, dass man für die Anwendung auch den Firefox nehmen kann, der wäre sogar besser dafür. Hätte ich mir den Zirkus mit dem IE auch ersparen können.

Firefox hat den Vorteil gegenüber dem IE, dass er die Anmeldedaten einer Webseite komplett speichern kann (der IE ist mit mehr als 2 Eingabefeldern anscheinend überfordert) und hat einen brauchbaren Web-Debugger eingebaut der mir jetzt zugute kam denn auch Firefox konnte die Seite nicht laden, zeigte mir aber an dass er ständig zwischen zwei Seiten pendelte.

Also mal das Javascript der Seite angehalten und im Einzelschritt durch den Quelltext durch. Da war was ganz komisches: Die Webseite generierte sich anhand der lokal eingestellten Uhrzeit irgendeinen Zeitstempel, der dann an den Server geschickt wurde. Der Server konnte nichts damit anfangen und leitete auf eine Fehlerseite (?) weiter die sofort wieder auf die Loginseite verwies wo das Spielchen von vorne losging.

Ich schielte auf die Windows-Systemuhr, die stimmte halbwegs (+4min, sollte jetzt kein Beinbruch sein). Nochmal in die Konfiguration der Uhr geschaut, einen anderen Zeitserver eingetragen und „synchronisieren“ gedückt – prompt sprang die Uhrzeit 2 Stunden zurück. Nicht ganz falsch, das ist die UTC, aber was macht die in dem Computer?

Aha – völlig falsche Zeitzone im Windows. Korrigiert und schon klappte das Login.

Jetzt frage ich mich ernsthaft: Welcher Webseitenentwickler schenkt der auf dem Computer eingestellten Uhrzeit irgendeinen Glauben?

Dieser Beitrag wurde unter Dies und das... veröffentlicht. Setze ein Lesezeichen auf den Permalink.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

*

This site uses Akismet to reduce spam. Learn how your comment data is processed.